Menu

viernes, 18 de mayo de 2012

Unidad 3: Manejo de Redes uso VLAN


­­­­­Identificación de elementos de las VLAN


Beneficios de una VLAN


Reducción del Coste de Movimientos y Cambios.
La principal excusa para implementar una VLAN es la reducción en el coste de los cambios y movimientos de usuarios. Desde que estos costes son bastante sustanciales, este argumento es suficientemente obligatorio para la implementación de una VLAN. Muchos fabricantes están prometiendo que la implementación de una VLAN resultará más conveniente a la hora de habilitar la administración de redes dinámicas, y que esto supondrá bastante ahorro. Esta promesa se puede aplicar con buenos resultados a redes IP, ya que, normalmente, cuando un usuario se mueve a una diferente subred, las direcciones IP han de ser actualizadas manualmente en la estación de trabajo. Este proceso consume gran cantidad de tiempo que podría ser aprovechado para otras tareas, tales como producir nuevos servicios de red. Una VLAN elimina ese hecho, porque los miembros de una red virtual no están atados a una localización física en la red, permitiendo que las estaciones cambiadas de sitio conserven su dirección IP original. Sin embargo, cualquier implementación de VLAN no reduce este coste. Una VLAN añade una nueva capa de conexión virtual que ha de ser administrada al mismo tiempo que la conexión física. Esto no quiere decir que no se puedan reducir los costes hablados anteriormente. Sólo que no hay que precipitarse a la hora de implementar una VLAN y es mejor estar bien seguro de que la solución no genera más trabajo de administración de red que el que se pueda ahorrar. El acceso a las VLAN está dividido en un rango normal o un rango extendido.

Rangos del ID de la VLAN


VLAN de rango normal       

Se utiliza en redes de pequeños y medianos negocios y empresas.
Se identifica mediante un ID de VLAN entre 1 y 1005.
Los ID de 1002 a 1005 se reservan para las VLAN Token Ring y FDDI.
Los ID 1 y 1002 a 1005 se crean automáticamente y no se pueden eliminar. Aprenderá más acerca de VLAN 1 más adelante en este capítulo.     
Las configuraciones se almacenan dentro de un archivo de datos de la VLAN, denominado VLAN.dat. El archivo VLAN.dat se encuentra en la memoria flash del switch.

El protocolo de enlace troncal de la VLAN (VTP), que ayuda a gestionar las configuraciones de la VLAN entre los switches, sólo puede asimilar las VLAN de rango normal y las almacena en el archivo de base de datos de la VLAN.

VLAN de rango extendido

Posibilita a los proveedores de servicios que amplíen sus infraestructuras a una cantidad de clientes mayor. Algunas empresas globales podrían ser lo suficientemente grandes como para necesitar los ID de las VLAN de rango extendido.
Se identifican mediante un ID de VLAN entre 1006 y 4094.
Admiten menos características de VLAN que las VLAN de rango normal.
Se guardan en el archivo de configuración en ejecución.
VTP no aprende las VLAN de rango extendido.

Tipos de VLAN

VLAN De Datos

Una VLAN de datos es una VLAN configurada para enviar sólo tráfico de datos generado por el usuario.

VLAN Predeterminada

Todos los puertos de switch se convierten en un miembro de la VLAN predeterminada luego del arranque inicial del switch. La VLAN predeterminada para los switches de Cisco es la VLAN 1. El tráfico de control de Capa 2, como CDP y el tráfico del protocolo spanning tree se asociará siempre con la VLAN 1.

VLAN Nativa

Una VLAN nativa está asignada a un puerto troncal 802.1Q. Un puerto de enlace troncal 802.1 Q admite el tráfico que llega de muchas VLAN (tráfico etiquetado) como también el tráfico que no llega de una VLAN (tráfico no etiquetado). Una VLAN nativa sirve como un identificador común en extremos opuestos de un enlace troncal.

VLAN de Administración

Una VLAN de administración es cualquier VLAN que usted configura para acceder a las capacidades de administración de un switch.

VLAN de Voz

Es fácil apreciar por qué se necesita una VLAN separada para admitir la Voz sobre IP (VoIP). Imagine que está recibiendo una llamada de urgencia y de repente la calidad de la transmisión se distorsiona tanto que no puede comprender lo que está diciendo la persona que llama. El tráfico de VoIP requiere:

Modos de Membresia de las Puertas Switch de VLAN

Cuando configura una VLAN, debe asignarle un número de ID y le puede dar un nombre si lo desea. El propósito de las implementaciones de la VLAN es asociar con criterio los puertos con las VLAN particulares. Se configura el puerto para enviar una trama a una VLAN específica. Como se mencionó anteriormente, el usuario puede configurar una VLAN en el modo de voz para admitir tráfico de datos y de voz que llega desde un teléfono IP de Cisco. El usuario puede configurar un puerto para que pertenezca a una VLAN mediante la asignación de un modo de membresía que especifique el tipo de tráfico que envía el puerto y las VLAN a las que puede pertenecer. Se puede configurar un puerto para que admita estos tipos de VLAN:
VLAN estática: los puertos en un switch se asignan manualmente a una VLAN. Las VLAN estáticas se configuran por medio de la utilización del CLI de Cisco. Esto también se puede llevar a cabo con las aplicaciones de administración de GUI, como el Asistente de red Cisco. Sin embargo, una característica conveniente del CLI es que si asigna una interfaz a una VLAN que no existe, se crea la nueva VLAN para el usuario. Para ver un ejemplo de configuración de VLAN estática, haga clic en el botón
Ejemplo de Modo Estático en la figura. Cuando haya finalizado, haga clic en el botón Modos de Puertos en la figura. Esta configuración no se examinará en detalle ahora. Se presentará más adelante en este capítulo.
VLAN dinámica: este modo no se utiliza ampliamente en las redes de producción y no se investiga en este curso. Sin embargo, es útil saber qué es una VLAN dinámica. La membresía de una VLAN de puerto dinámico se configura utilizando un servidor especial denominado Servidor de política de membresía de VLAN (VMPS). Con el
VMPS, asigna puertos de switch a las VLAN basadas en forma dinámica en la dirección MAC de origen del dispositivo conectado al puerto. El beneficio llega cuando traslada un host desde un puerto en un switch en la red hacia un puerto sobre otro switch en la red. El switch asigna en forma dinámica el puerto nuevo a la VLAN adecuada para ese host.

 

Enlace troncal de la VLAN

Un enlace Troncal es otro tipo de puerto de capa 2 soportado por los switching cisco. Cuando se configura un puerto troncal, empieza marcando las tramas o medidas que salen del puerto para indicar la VLAN a la que cada trama esta asociada. El puerto troncal también puede leer las marcas denominadas etiquetas, a medida que entran en el puerto troncal este permite que el switch envíe una trama solo a los puertos de la VLAN asociada a la trama entrante. El propósito principal del Trunking es transportar Tráfico entre switches y mantener información VLAN a diferencia de un enlace acceso, el enlace troncal no pertenece a una sola VLAN, pero en cambio puede transportar tráfico de varias VLAN.

Etiquetado de trama de 802.1Q

El protocolo 802.1Q es un proyecto de la IEEE para crear una forma para compartir de forma transparente medios físicos entre múltiples redes, tratando de que no haya interferencias entre ellas
Este protocolo interconecta switches, Reuters y servidores, a través de los puertos FastEthernet y Gigabit Ethernet.
En este protocolo, que funciona a nivel de la capa 2, las estaciones no tienen conocimiento de la VLAN, cada trama se marcará con un identificador de la VLAN a la que está vinculada (esto para asignar prioridades a los paquetes.)

CONCLUCION

La funcionalidad de VLAN es hacer que un switch tenga varios segmentos por ejemplo podemos crear varias conexiones con distintas  segmentos pero conectados a la misma red,  y configurar cada maquina con un segmento con la que queremos que las maquinas se vean, igual la funcionalidad del VLAN  es dividir las entradas de switch asignando un determinado puerto serial a cada segmento las maquinas que se conecten en el mismo segmento  asignada por la VLAN se podrán ver pero las de mas conectadas con otras entras distintas no se podrán ver, para que puedan enviar información se tiene que hacer un puerto de enlace conectando una Reuters. 


Diagrama de VLAN EJEMPLO

Ejemplo de uso de VLAN con dos segmentos utilizando un switch y un Reuter, 2 de las computadoras tienen un IP y las otras diferente IP.

Configuración del switch de dos segmentos

Switch>EN
Switch#CONF T
Switch(config)#VLAN 2
Switch(config-vlan)#name primer
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#name segundo
Switch(config-vlan)#exit
Switch(config)#interface range fastethernet 0/2-7
Switch(config-if-range)#switchport access vlan 2
Switch(config-if-range)#exit
Switch(config)#interface range fastethernet 0/8-13
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)#exit
Switch(config)#end
Switch#show vlan
Switch#
Switch#copy running-config startup-config
Switch>en
Switch#conf t
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#end
Switch#

Configuración del Reuter para que se comuniquen los dos segmentos


Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastethernet 0/0.1
Router(config-subif)#encapsulation dot1q 2
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#interface fastethernet 0/0.2
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#end
Router#copy running-config startup-config
Router#conf t
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router#copy running-config startup-config
Router#


VLAN
PUERTOS
MULAN
IP
PRIMER SERVICIO
0/2-0/7
2
192.168.1.0
SEGUNDO SERVICIO
0/9-0/13
3
192.168.2.0

Ficha técnica


SWITCH CORE
Todos los switches deben incluir los módulos y cables que permitan su correcto funcionamiento
Garantiza que la solución sea administrable tanto por puerto de consola como por interfaz grafica web
Garantiza que la solución cuente con modulo de administración instalado, CLI, WEB, TELNET o SSH
Garantizar que la solución cumpla con los siguientes estándares:
•IEEE802.1d Bridging
• IEEE 802.1D Spanning Tree Protocol
• IEEE 801.p Class of Service
• IEEE 802.1P
Traffic filtering, dynamic multicast filtering
• IEEE 802.1Q VLAN bridge
• IEEE 802.1w Rapid Spanning Tree
• IEEE 802.1x Port-based network access control
• GVRP• PVST+
Garantizar que la solución cuente con desempeño y disponibilidad:
•4Krutas IPv4 y 2.5K rutas IPv6
• Soportar estándares SNMP v1, v2 y v3
• El ancho efectivo real será de 19” pulgadas
• Los puertos de cobre deben soportar auto negociación de velocidad (10, 100 y 1000 Mbps) y del modo dúplex (half or full)
• Los puertos de cobre deben soportar funcionamiento automático MDI/MDIX
• Soporte de al menos de 16K direcciones MAC
• Todos los puertos suministrados deben ser nivel 2, 3 y 4 según el modelo de referencia OSI y la pila TCP/IP;